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Building Information Modeling (BIM) is transferring the architecture, engineering and construction industry. BIM creates efficiency through its potential to

cut down a re-keying information into models or making changes in the field. It encourages a more collaborative environment and also has a high focus on

sustainability in building design. Autodesk Revit is one of the few digital design software packages that incorporate BIM and focus more on the architectural

sector. It allows you to create models and drawings focusing on the core tenets of building information modelling. The key element in Revit is the

relationship between 2D drawings and 3D models, compared to other design software packages that require the users to create these drawing separately.

Using Revit, you could make a change in the 3D model, and the 2D drawings you extract will reflect that change. The same is true if you change one of the 2D

drawings. “A CHANGE ANYWHERE IS A CHANGE EVERYWHERE” This automation lies at the core of the Revit software.

With all the advantages that the package offers, Revit is a very powerful and complex design software to learn. Students will generally

struggle to understand, memorizes and apply the complicated step to put their design idea into drawings and models. Lecturers, on the other hands, have

limited face to face time to guide and demonstrate the process. Hence, this note is written as a simplified manual that will benefit both students and

lecturers, or even designers and architects who has no exposure to Revit before. This note is targeted to guide you through the learning process for the

development of models using Revit. The step-by-step basic training guide provided in this note will help beginners understand the fundamentals of the

software either for self-study or for a training program. In addition, the unique feature of this manual is you can find a QR Code that will direct you to a

related tutorial video at the end of every topic.

You will love this note. The simplified guideline with tutorial video will be super helpful for you to start your Revit Journey

~ author ~

F o r e w o r d v
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I N T R O D U C T I O N



Autodesk Revit is a Building Information Modeling (BIM) software for Microsoft Windows, which allows the user to 

design with parametric modeling and drafting elements.

W H A T   I S   R E V I T ? 

Revit is a single file database that can be shared among multiple users. Plans, sections, elevations, legends, 

schedules are all interconnected, and if a user makes a change in one view, the other views are automatically 

updated.

02
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W H A T   I S   R E V I T ? 

“ A CHANGE ANYWHERE IS A CHANGE EVERYWHERE”. 

https://www.youtube.com/watch?v=_qqT9j0rzuk



N E W   P R O J E C T 

CLICK HERE

But make sure the 

template is using 

metric unit

1

2 CLICK FILE 

MENU

OR

>  click New > Project > click the 

Browse button

>  select US Metric > select 

Default Metric > click Open > 

click OK

select Up one level icon to choose template >

04



N E W   P R O J E C T 

05

STARTING PROJECTS IN REVIT

https://www.youtube.com/watch?v=rMtnRsonhSc



I N T E R F A C E

1

8

QUICK LINKS

3 RIBBON

2 TABS

4 PROPERTIES

5 PROJECT BROWSER

6 VIEW CONTROL BAR

7 STATUS BAR

DRAWING AREA

06



I N T E R F A C E

07

The Properties palette is a modeless dialog where you can view and modify the

parameters that define the properties of elements.

Note: For information about instance or type properties related to a specific

element type, use the search function. Search for <Element Name> <instance

or type> properties. Example: stair instance properties

The Quick Access toolbar contains a set of default tools. You can customize

this toolbar to display the tools that you use most often

1 QUICK LINKS

2 TABS

3 RIBBON

4 PROPERTIES

5 PROJECT BROWSER

6 VIEW CONTROL BAR

7 STATUS BAR

8 DRAWING AREA

The File tab provides access to common file actions, such as New, Open, and 

Save. It also allows you to manage files using more advanced tools, such as 

Export and Publish

The Project Browser shows a logical hierarchy for all views, schedules, sheets,

groups, and other parts of the current project. As you expand and collapse each

branch, lower-level items display

The drawing area displays views (and sheets and schedules) of the current

project. Each time you open a view in a project, the view displays in the

drawing area on top of other open views.

The status bar provides tips or hints on what to do. When you highlight an

element or component, the status bar displays the name of the family and type.

The View Control Bar is located at the bottom of the view window above the status

bar and includes the following tools:

The ribbon displays when you create or open a file. It provides all the tools

necessary to create a project or family.



I N T E R F A C E

USER INTERFACE

https://www.youtube.com/watch?v=gLixZ2Whtc4

08



M A S S I N G   &   S I T E



M A S S I N G

09

Autodesk® Revit® massing is a powerful tool for generating masses

that works at any scale, whether you're at the conceptual level of a

building, at the detailed level refining the fixings and furniture, or

working on an entire masterplan.

Creating organic forms in Revit. Complex forms can be derived from

the massing tools, which, when loaded in a project, can be turned into

building components. Massing components can be loaded in a project and

then turned into building components

Figure 1: Create complex form using massing tool Figure 2: Massing form turned into building components



M A S S I N G

10

CREATE A MASS IN THE CURRENT PROJECT.

1. Click Massing & Site tab > (In-Place Mass).

2. In a dialog box > Enter a name for the in-place mass family > click OK.

3. Create the new shapes using the tools on the Draw panel.

4. Forms are created by drawing lines and closed loops > click (Create

Form).

*This tools can develop or manipulate any surface, 3D solid or void form.

1

2

3

4



CREATE NEGATIVE GEOMETRY (VOIDS) TO CUT SOLID GEOMETRY USING

CREATE VOID TOOL.

1. On the Create tab > Draw panel, select one of the drawing tool.

2. Click in the drawing area > draw a close loop.

3. Select the closed loop.

4. Click Modify > Form panel > Create Form > (Void Form) > A void

form extrusion is created.

5. To convert this void form to solid form > Click Modify > Form panel >

select void form > (Solid Form).

CREATE SOLID GEOMETRY USING CREATE FORM TOOL.

1. On the Create tab > Draw panel > select one of the drawing tool.

2. Click in the drawing area > draw a close loop.

3. Select the closed loop.

4. Click Modify > Form panel > (Create Form) > (Solid Form) > A

solid form extrusion is created.

5. You can change the dimension of the solid form by editing the

temporary dimension in the drawing area or drag the form using the 3D

drag controls.

M A S S I N G

11



M A S S I N G
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CREATE A FLOOR AREA FACES

1. Create more level in an elevation view by using the Level tool on

the Architecture Tab.

2. Select all the masses > click the Mass Floors button from the

Model panel.

3. You will get the Mass Floors dialog box > Select all the level >

Click OK.

4. Floor faces will intersect the solid masses.

5. Finally you change the masses into building elements (floors,

wall, roof)

1

2

3

4

5



M A S S I N G

MANIPULATING THE MASSES FORM

The masses can be manipulate before turn it into building elements by

modify /add solid or void form. You can also rotate it or modified the

surface point.

13



M A S S I N G

14

MASSING IN REVIT

https://www.youtube.com/watch?v=VjNzUUUPDfk



T O P O G R A P H Y

Create a Toposurface by Defining Points

1. Open a 3D view or a site plan view.

2. Click Masing & Site tab > Model Site panel > Toposurface > the Place

Point tool on the ribbon is active.

3. On the Option Bar, set a value for Elevation.

4. Next to the elevation text box, select one of the following: Absolute

Elevation to edit an existing toposurface by placing points on it at the

elevation you specify. (To use this option effectively, you may work in a

shaded 3D view)

5. Click the drawing area to place points. If needed > click Modify > Edit

Surface to edit the place points and the elevation.

6. Click (Finish Surface)

1

2

OR

DOUBLE CLICK HERE

15

3

4



T O P O G R A P H Y

16

5

6

Create a Subregion

1. Open a site plan that displays toposurface.

2. Click Masing & Site tab > Model Site panel > (Subregion)

3. On sketch mode > Click (Pick Lines) or another sketching tool create

the subregion

4. To modify subregion > Select the subregion > Click Modify I

Topography panel > Edit Boundary.

5. On sketch mode > Click (Pick Lines) or another sketching tool to

modify the subregion.



T O P O G R A P H Y

ROAD AND PATHWAY IN REVIT

https://www.youtube.com/watch?v=L4hNX-yvAPQ
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L A N D S C A P E

18

Add a tree

1. Open a 3D view or site plan view.

2. Open the Plant Manager (Site Component) > choose the tree or shrub 

you want to place. 

3. Move your cursor to site plan > Click to begin placing the tree or shrub. 

1

2 3



L A N D S C A P E

3D LANDSCAPE DIAGRAM

https://www.youtube.com/watch?v=L4hNX-yvAPQ

19



D R A W I N G S   &   3 D ’S



I M P O R T   C A D

TO IMPORT DATA FROM CAD PROGRAM

1. Click Insert tab > Import panel > (Import Cad)

2. Select the desire file type > select the file to import

3. Specify option > check the important file information; (Import units)

and location to open the file (Place at) > click Open

4. Moves the cursor to drawing area > Click to place the imported data.

5. To modify the unit or scale: Select the imported CAD file > click

Modify > at properties panel click (Edit Type) > you can change the

import units & scale factor > click OK

2

1

3

4

20



I M P O R T   C A D

21

AUTOCAD TO REVIT IMPORT

https://www.youtube.com/watch?v=aXPkDP0IK2o&t=2s



W A L L

Wall tool is used to create a non-bearing wall or a structural wall in the

building model.

You can add walls to a building model by clicking the Wall tool,

selecting the desired wall type and placing it in a plan view or 3D view.

1

2

3

22



W A L L

23

CREATING ARCHITECTURE WALL OR STRUCTURAL WALL

1. Open a floor plan or a 3D view.

2. Click Architecture tab > Build panel > Wall drop-down

> (Wall: Architecture)

3. You can chose other types than one displayed in the

Type Selector by selecting a different type from the

drop-down.

4. On the Properties panel > specify the following

information: *(refer to step 4 diagram)

2

3 4

CLICK TO 

EDIT



W A L L

CUSTOMIZE THE SELECTED WALL

1. Click Edit Type

2. In the dialog box of Type Properties > click (preview) >

click (Duplicate) to rename your wall type > click OK

> click Edit to open Edit Assembly dialog box.

3. On the Edit Assembly dialog box > click (Insert) to add layers for

material > choose the material and set the thickness > click OK

2

3

1

CLICK HERE

i

ii

iii

24



W A L L

25

After you place a wall in a drawing, you can add sweeps or reveals, edit the wall’s 

profile, and insert hosted components such as doors and windows.



W A L L

NON-RECTANGULAR WALLS AND CUT OPENINGS

You cannot edit the elevation profile of a wall that is an arc in plan view, but

you can edit in section or elevation view. Use the Wall Opening tool to

place rectangular openings in an arc wall.

To edit the profile of a wall:

1. In the drawing area, select the wall > at Modify I Walls tab, Click (Edit

Profile)

2. Use the tools on Modify and Draw panels to edit the profile as needed.

3. You can delete the lines and sketch a different shape or draw openings

and holes at the wall.

4. When you finished > click (Finish Edit Mode)

1

2

3

4

Tip: To create a non-rectangular wall on a

vertical cylindrical face, use openings and in-

place cuts to adjust its profile

26



W A L L

27

CREATE WALL FROM MASS FACES

1. Open a view that displays the mass

2. On the Architecture tab select Wall > Wall by Face

3. In the Properties panel, select wall type > specify the wall information

(location, height,…etc)

4. Move the cursor to highlight a face > click to select a face > the faces you

selected will turn into a wall.

2

3

4



W A L L

WALLS IN REVIT

https://www.youtube.com/watch?v=LGnmSFsxtHo

28



D O O R S   &   W I N D O W S

29

Doors and windows in the Autodesk Revit software are designed to be

hosted by walls. You can use temporary dimensions as well as alignment

lines and snaps to help place the openings exactly where you need them in

the walls.

ADD A DOOR OR WINDOW

1. In the Architecture tab > Build panel > click Door or windows

2. On the Properties panel dialog box > choose the type of door/window

> move your cursor to the desired location at your wall.

3. To modify your door/window > click Edit Type > you can change the

property information.

1

2



D O O R S   &   W I N D O W S

HOW TO ADD DOORS AND WINDOWS

https://www.youtube.com/watch?v=Y1yYMims-fQ&t=55s 

30



F L O O R   &   S L A B

31

CREATE A FLOOR

To create a floor, define its boundaries by picking walls or sketching its profile

with drawing tools.

1. Click Architecture tab > Floor drop-down > (Floor: Architecture)

2. You can choose other types than the one displayed in the Type Selector,

select a different type from the drop-down.

3. On the Properties panel > specify floor information or > click Edit Type

to customize or to create a new floor

4. Draw the floor boundaries by sketching the profile of the floor > click

Modify I Create Floor Boundary tab > Draw panel > select a sketching

tool or select Pick Walls

5. The floor boundary must be a closed-loop.

6. Click (Finish Edit Mode)

1

2 3

4

FINISH EDIT MODE



F L O O R   &   S L A B

HOW TO WORK WITH FLOORS

https://www.youtube.com/watch?v=F6q9yJGSiqc

32



1. Display a floor plan view or a ceiling plan view.

2. Click Architecture tab > Build panel > Roof drop-down > click Roof

by Footprint. (Make sure you are at the highest level before adding the

roof)

3. On the Draw panel > select sketch or pick tool > Use properties palette

to edit roof type/information.

4. If you use Pick tools, you can specify the overhang before you sketch the

roof. On the Option Bar > select Extend to wall core > specify the value

of overhang.

5. Sketch or pick a closed loop for the roof.

6. Specify slope-defining lines. You can change the slope value on the

Properties palette. Click Defines Roof Slope > change the slope value

7. Click (Finish Edit Mode) > open 3D view

R O O F

33

CREATE A ROOF BY FOOTPRINT

ADD A ROOF TO ANOTHER ROOF

1. Select the roof in the drawing area.

2. On the Properties palette > specify a Cutoff Level > specify a height for

Cutoff Offset.

3. Sketch the new roof on the top of the existing roof

JOIN ROOF

1. Click Modify tab > Geometry panel > (Join/Unjoin Roof).

2. Select the edge of the roof that you want to join > select the wall or

roof to which you want to join the roof.

3. To unjoin roof > click Modify tab > Geometry panel > (Join/Unjoin

Roof).

*click the roof line to change the 

slope value



R O O F

CREATE A ROOF BY EXTRUSION

1. Display a floor plan view or a ceiling plan view.

2. Click Architecture tab > Build panel > Roof drop-down > click Roof by

Extrusion.

3. Specify the work plane > select Pick a plane

4. In the Roof Reference Level and Offset dialog > select a value of level >

The highest level in the project is selected by default.

5. Sketch the profile of the roof as an open loop

6. Click (Finish Edit Mode) > open 3D view.

3 4

5 6

34

Pick plane

Profile line



R O O F

35

CREATE A ROOF SLOPE USING THE DEFINES SLOPE PROPERTY

You can create different roof types, including flat roofs, gable roofs and hip roofs

by applying the Defines Slope property to lines of a roof boundary

1. In sketch mode, select a roof boundary line that defines the slope

2. On the Properties palette > select or clear Defines Roof Slope.

3. To specify roof pitch > select a slope-defining boundary line > click the

numeric slope in the drawing area > enter a new value for the slope.

One slope line form a single pitch roof

Two opposite sloped lines form a gable

Three or four sloped lines form a hip roof

Different sloped lines create different result

Clear define roof slope



CREATE A ROOF SLOPE USING SLOPE ARROWS

You can use slope arrows to create slopes on a roof.

1. On the Properties palette > specify a cutoff level for the roof. If you are

sketching the roof on level 2, you can specify level 4 as the cutoff level.

2. Click (Finish Edit Mode)

3. Create another footprint roof sketch at a higher level as the following:

4. Click (Finish Edit Mode)

5. In 3D view, select both roof > click Modify tab > Geometry panel >

(Join/Unjoin Roof)

R O O F

Single roof with different eaves heights

36



CREATE A FOUR SIDED GABLE ROOF

1. Create a rectangular footprint sketch and designated all sketch lines

as non-slope-defining. The reference plane in the sketch indicates

where the 4 sided gable roof stop.

2. Click Modify I Create Roof by Footprint tab > Draw panel > (Slope

Arrow)

3. On the Properties palette > select New –Sketch- from the filter list.

4. Under Constraints for Specify > select Slope

5. Under Dimension for Slope > enter value

6. Sketch slope arrow as shown.

7. Click (Finish Edit Mode)

8. Open the roof in 3D

R O O F

37



R O O F

COMMON ROOF SHAPES

https://www.youtube.com/watch?v=enrmG9CMUfE&t=12s

38



S T A I R S

39

CREATE A STRAIGHT RUN

1. Select the straight run component tool > On properties panel, edit the

information.

2. In the drawing area > click to specify the start point.

3. Move the cursor to draw the run > click to specify the end of the run

and specify total number of risers.

4. Click (Finish edit Mode)

1

2

3

*tips

* specify the start point and endpoint of the run



S T A I R S

CREATE 2 PERPENDICULAR RUNS CONNECTED BY LANDING

1. Select the straight run component tool > specify initial option and

properties.

2. On the Option Bar > select a value for Location Line > verify the

Automatic Landing is selected

3. Click to specify the start point > click to position the landing when

the desired number of risers has been reached.

4. Move the cursor along the extension line > click to continue

drawing the remaining riser for the second run.

5. Click to finish the second run

6. Click (Finish edit Mode)

1

3

4

2

40



S T A I R S

41

CREATE A FULL STEP SPIRAL RUN

Create a spiral stair run component by specifying the start point and the radius.

You can use the Full-Step Spiral run tool to create a spiral run that is greater than 360 

degrees.

• The run is created with the full number of steps to connect the base and top elevations.

• The spiral run is created in the counter-clockwise direction by default.

• Use the Flip tool to change the direction in stair edit mode.

To create a full-step spiral run

1. Select the Full-Step Spiral run component tool and specify initial options and

properties.

2. In the drawing area > click to specify the center point of the spiral run.

3. Move the cursor to specify the radius of the run > as you draw, a tooltips indicates

the run boundary and full steps required to reach the target level.

4. Click to complete the run.

1

2 3

4



S T A I R S

CREATE A CENTER-ENDS SPIRAL RUN

Center-Ends Spiral run tool can create a spiral run that is greater than 

360 degrees.

To create a single spiral run

1. Select the Center-Ends Spiral run component tool

2. In the drawing area > click to specify the center point of the spiral

run.

3. Move the cursor clockwise or counter-clockwise to set the turn

direction (To change the direction of the stairs, use the Flip tool in

stair edit mode) > click to specify the endpoint and the total

number of risers.

4. Click (Finish edit Mode)

1 2

3

4

42

* specify the center point, start point and endpoint for the run



S T A I R S

43

CREATE AN L-SHAPE OR U-SHAPE WINDER RUN

1. Select the winder run component tool >

2. On the Option Bar > select Exterior Support: Left/right.

3. On the Option Bar > clear or select Mirror Preview to change the

default winder layout direction.

4. Press the spacebar to rotate the shape of the winder run to the

required direction.

5. Click to place the winder run.

6. To modify stair components > use the direct manipulation control

7. Click (Finish edit Mode)

1

2

5

* specify the lower endpoint of the run, the winder run will 

automatically connect the base and the top elevations.



S T A I R S

CREATE A MULTISTORY STAIRS

1. In stair creation mode > click Modify I Create Stair tab > Edit panel

> (Multistory Stair panel > Multistory: Select Levels)

2. Select a stair in an elevation/section view > click Modify I Stair tab

> Multistory Stair panel > Multistory: Select Levels.

1

2

44

* Multistory stairs will automatically adjust if level heights change



S T A I R S

45

STAIRS IN REVIT

https://www.youtube.com/watch?v=oYBzpTacMCQ&t=1s



R A M P

CREATE A RAMP

You can create a ramp in a plan or 3D view by sketching the run of the ramp 

or by sketching the boundary lines.

1. Click Architecture tab > Ramp

2. Click Run to sketch a straight run or Create Ramp Sketch by selecting

or

3. On the Properties panel > click Edit Type to edit/set up the

specification > Click OK

4. Place the cursor in the drawing area > drag to sketch the ramp run.

5. Click (Finish Edit Mode)

1 2

3 4

46



R A I L I N G

47

CREATE A RAILING BY RAILING PATH AND HOST

Create a railing by sketching the railing path and select an element to host 

the railing such as floor or roof.

1. Click Architecture tab > Railing drop-down > (sketch Path).

2. To set the host for the railing, click Modify I Create Railing path tab

> Tools panel > (Pick New Host) > place the cursor near the host (for

example: floor, staircase, topographic surface…etc)

3. Click on the host to select.

4. Sketch the railing within the boundary of the host element.

5. You can modify instance properties as needed on the properties

palette or click (Edit Type) to access and modify type properties.

6. Click (Finish edit Mode).

1

2 3

6



R A I L I N G

MODIFY A RAILING

You can modify a railing by editing the path, railing structure and

railing properties. Modifying the railing structure allow you to change

the height of the railing, the shape used for each rail and the number

of rails.

To modify a railing sketch

1. Select the railing > on the Modify tab > click (Edit Path)

2. Use tools from the Draw Panel to modify the sketch.

3. Click the Sketch Orientation arrows to change the start and end

points of the railing sketch.

To modify railing type properties

1. Select the railing > on the Properties palette > click (Edit Type)

2. In the Type Properties dialog > specify properties for the rail

and balusters

3. To modify the Type Properties for the top rail or handrail > click

in the Value field for the Type > click the browse button.

4. Make any changes > click Apply to view your changes in the

Preview panel.

1 2

1

3

2

48



C O L U M N

49

ADD A COLUMN

You can add columns in plan views and 3D views. 

1. Click Architecture tab > Column drop-down > (Column:

Architectural).

2. On the Option Bar, specify the information needed > click

(Edit Type) to customize your column.

3. In the drawing area > click to place the column. You can move

the column by drag it to new position.

1

2 3

OR



C O M P O N E N T S

PLACE A COMPONENT

A freestanding component can be placed into building model that is 

appropriate for the type of component you want to place.

For example, you can place a furniture in a plan or 3D view, but not in a 

section or elevation.

1. Click Architecture tab > Build panel > Component drop-down >

(Place a Component).

2. Select the desired component type.

3. On properties panel > click Edit Type to modify the specification.

4. Place the component at the desired location.

1 2

3 4

50



R E N D E R I N G   ( I M A G E S )



P E R S P E C T I V E S

CREATE A PERSPECTIVES VIEW

1. Open a plan, section or elevation view.

2. Click View tab > 3D View drop-down > Camera.

3. In the drawing area > click to place the camera.

4. Drag the cursor to the desired view > click to place it.

5. You can use a section box to expand or limit the viewable portion of

a 3D view.

2

3 5

4

51



P E R S P E C T I V E S

52

RENDER A PERSPECTIVES VIEW

1. After preparing the 3D view > click Render to render the image.

2. On Rendering dialog box > set up the following criteria (refer to figure 2)

3. Click Render > Revit begins rendering the entire image progressively. (The

rendering process is displayed in a progress dialog)

4. When the process is completed, Revit displays the rendered image in the

drawing area.

5. On the rendering dialog box > Click Adjust Exposure (refer to figure 5) >

Click Apply > OK

1

2

For first time render always set 

Quality Setting to Draft

ii

iii

i

i

ii

iii
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After you are satisfied with

exposure quality > repeat the

rendering process by selecting

Medium/High Quality Setting >

Click Render

5

You can create a different environment (day & night) or moods with proper Rendering Setting set up and Exposure Control adjustment.

draft rendering quality

high rendering quality
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draft rendering quality

54

TIPS FOR AMAZING RENDERINGS IN REVIT

https://www.youtube.com/watch?v=IW4Ts0iyzMQ&t=90s
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RENDER A SECTIONAL PERSPECTIVES VIEW

1. After preparing the 3D view > At Properties dialog box select Section

Box

2. On Project Browser panel > Select Floor Plan view > Right click at the

3D view > select Show Section Box.

3. You can adjust the Section Box by moving the control arrow.

4. Open the 3D view by double click on the Project Browser panel.

5. To render the view, apply the same rendering process as before.

1 2

3

4
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3D SECTION IN REVIT

https://www.youtube.com/watch?v=EgKGnItawE0
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RENDER A 2D VIEW DRAWING ( FLOOR PLAN /SITE PLAN/ELEVATION)

1. Change the view to 3D mode.

2. Select the 2D view in 3D mode.

3. Choose a suitable scale.

4. On Rendering dialog box > set up the following criteria (refer to figure 4)

5. Apply the same rendering process as before.

1

2

3

4

5

*Your rendered view will be in png format

(without background)
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RENDERING 2D VIEWS IN REVIT

https://www.youtube.com/watch?v=Sj622D8jX2Y&t=13s
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W A L K T H R O U G H

Walkthrough is a simulated tour of a site or building using camera

positions placed along a path that you define to present your model to

clients or team members.

The walkthrough path consists of camera frames and key-frames. A key-

frame is frame that can be modified to change the direction and position 

of the camera.

CREATE A WALKTHROUGH

1. Open a view to place a walkthrough path. *(any view but it’s easier

in plan view)

2. Click View tab > 3D view drop-down > (Walkthrough)

3. Place a key-frame > position the cursor in a view > specify the height

(Offset) of the path and camera > click to place a key-frame > move

the cursor to the desired direction to draw the path.

4. Continue placing key-frames to create the walkthrough path. You

cannot change camera position while creating the path but you can

Edit key-frames after finish the path.

5. To complete Walkthrough > Click Finish Walkthrough / Double-click

to end the path / Press Esc

2

3

4

5
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REVISE AND REVIEW A WALKTHROUGH

To edit the Walkthrough Path

When revising the walkthrough you can reposition the key-frames to 

change the path through the model.

1. Right-click the walkthrough in the Project Browser > select Show

Camera.

2. To move the entire walkthrough path > drag the path to the desired

location. You can also use the Move tool.

3. To edit the path > click Modify I Camera tab > Walkthrough

panel > (Edit Walkthrough)

4. You can select the Key Frame to modify the direction and position

of the camera. (select Previous Key Frame or Next Key Frame)

5. Drag the key-frame indicators to reposition the path.

3

4

5 The triangle represent

the camera view

capturedDrag this point to widen

the view

Adjust this point to control the

camera direction
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REVISE AND REVIEW & PLAYBACK A WALKTHROUGH

After creating a walkthrough you revise and review it to achieve the best

presentation.

To open the walkthrough and set up views

1. Right-click the walkthrough in the Project Browser > select Show

Camera.

2. Click Modify I Camera tab > (Edit Walkthrough) > (Open Walkthrough)

3. Open the site plan or other views that allow you to see different

walkthrough angles and tile them so you can see them all at the same

time.

4. Use the Previous Frame, Previous Key Frame, Next Frame and Play

controls to review and play back the walkthrough.

3

Click to play

You can reduce the frame value to make your

walkthrough move faster or add the value to make

it slower

Drag this point to control the view
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RENDER & EXPORT A WALKTHROUGH

To export a walkthrough

1. Open the walkthrough view > In the Project Browser > double-click the

walkthrough name to open it

2. Click file tab > Export > (Images and Animation) > (Walkthrough).

3. Under Output Length

• Specify the frames to include. Select all frames or select Frame

range to indicate the start and end frames.

• Adjust frames/sec > the total time will automatically update.

4. Under format > specify values for visual style, Dimensions and zoom to

the desired values > click OK

5. Navigate to the desired folder > select the file type > Click Save.

6. If you selected the AVI file, click Cancel at the bottom of the screen or

press Esc.

2

3

Before you export a walkthrough (rendering), render

your view as an image first and proceed to walkthrough

rendering after being satisfied with the rendering

outcome.

*tips4
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ANIMATION IN REVIT

https://www.youtube.com/watch?v=s9JrRspbyPE
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S H E E T S

CREATE A SHEET

1. On a Project Browser panel > right click on Sheets > Select New Sheet...

2. On New Sheet dialog box > select desired titleblocks or click Load… to

choose other paper size /titleblocks.

3. Click OK.

4. To add views to sheets > Click the view > drag it to the sheet > release

the button > click to place the view.

1

2

3

65



D R A W I N G   S A M P L E



S A M P L E

~ N U R   A I M A N   M U R I D O N ~
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~ N O R S H A H I R U L   S Y A Z W A N~

68



S A M P L E

69

~ A R S H A D   B I N   S I R A J~



S A M P L E

~ N O R S H A H I R U L   S Y A Z W A N~
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S A M P L E

FLOOR PLAN

SECTIONAL PERSPECTIVE

FRONT ELEVATION SIDE ELEVATION SECTION
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